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EXCEL 2016 – FORMULA BASICS 
 

 
Target Audience: This class is designed for Excel users with a solid understanding of the basics of 

spreadsheets who wish to perform more complex operations. 
Time Allotted: 3 hours 

 

Objectives: 
 

Overall: Understand how to effectively use the advanced formatting features available in Excel to 
quickly and efficiently format large amounts of data. This class will also teach skills related 
to understanding and using basic formulas and functions.  

 
Specific: Participant will… 

 Filter and sort data in a worksheet 
 Define mathematical operators and demonstrate proper use 
 Construct basic formulas to perform calculations  
 Practice common functions such as: CONCATENATE, UPPER, IF, TRIM, and TODAY 
 Practice the Subtotal, Text to Columns, Conditional Formatting, and Remove Duplicate 

features  
 

 
Agenda Notes 

 

 Housekeeping 

 Introductions 

 Filter and Sort  

 Conditional Formatting 

 Calculation Order  

 Building Formulas 

 Mathematical Operators 

 Functions  

 Data Tab Features 
o Subtotals 
o Remove Duplicates 
o What-if Analysis 
 

 

 

Introduction Activity Notes 
 

Please tell us: 

 Your Name 

 Your Department 

 What you hope to get out of today’s session 
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Filter Data Notes 
 

1. Click on any cell in your data. 
2. Click Filter (Data tab, Sort and Filter group) 

 The filter will be applied to the column header row 
3. To use the filter: 

 Click the arrow  
o  Select one or more values to filter data by  

NOTE: When a column is filtered the  icon will show. Click on Select All to un-filter 
data. 

 

 

Sort Data - Simple Sort Notes 
 

When you sort data, you can select data in a range that goes across columns and rows, or a 
range that is a single column. The range can include titles (headers) that you create to 
identify columns or rows. 

 
1. Click on a cell in the data range you wish to sort. 

NOTE: If the data you are sorting has headers, you will need to indicate this so that Excel 
does not include the headers in the sort. To indicate that your data has headers, click on 
the Sort button and ensure that the check-box for My data has headers is checked. 

2. Select the preferred sort order, either A to Z (or lowest number to highest) or Z to A (or 
highest number to lowest). 

  

3. The spreadsheet will automatically sort. 
 

 

Sort Data - Multi Level Sort Notes 
 

1. Select the data to sort. 
2. Click the Sort button. 
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3. The custom sort box will open. 

 

4. Use the drop down menus to select criteria for the first level of sorting. 

 

5. Click Add Level and then repeat step 4 if you wish to sort by additional columns. 
6. Click OK when you have finished selecting your sort criteria and are ready to sort. 
 
Sort By Date Notes 

 
Dates can also be sorted, with either the oldest date on top or the newest date on top. 
 
To Sort By Date 
1. Select all of the dates in the column to sort. 
2. On the Home tab, in the Editing group, click the arrow under Sort & Filter. 
3. Select either Sort Oldest to Newest or Sort Newest to Oldest. 

NOTE: If the results are not what you expected, the column might contain dates stored as 
text. 
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Exercise #1 Notes 
 
1. Open the Formulas and Functions Exercises file. 
2. Using the data in the Exercise 1 tab, add filters and utilize sort tools as appropriate to get 

answers to the following: 
 

State with highest number of murders  

State with lowest number of murders  

State with lowest number of robberies  

State with highest number of robberies  

Midwest state with the largest # police  

Northern state with lowest number of 
robberies 

 

Northern state with lowest percentage 
urban population 

 

Number of states in the West beginning 
with A or W 

 

West A and W states that has the 
highest number of robberies 

 

 
 

 

Conditional Formatting Notes 
 
Conditional formatting helps you highlight specific data and emphasize values in a worksheet by 
formatting cells based on a criteria or condition that you specify in a rule. If the condition is 
fulfilled, the formatting is applied to the cells.  
 
Format cells based on their values 
Using this rule, you can format a range of cells by using 2-color scales, 3-color scales, data bars, 
and icon sets.  
 
Format only cells that contain 
Using this rule, you can format cells that contain values in a certain range. You can format cells 
that contain text beginning with, ending with, or containing specific characters. You can use this 
rule to highlight dates occurring in the last week, month, or across other time intervals. You can 
highlight blanks, no blanks, errors, and no errors in a worksheet. 
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Format only top or bottom ranked values 
Using this rule, you can format the top or bottom 10 values in the selected cell range. In 
addition, you can also format the values that rank in a specified top or bottom percent of the 
selected range. For example, you can choose to format the values that rank in the top 10 
percent of the selected range. Then, you can click the Format button to specify the formatting to 
be applied to the cells that contain those values. 
 
Format only values that are above or below average 
Using this rule, you can format the cells that contain values that are above or below average for 
the selected cell range. You can also format the cells that contain values 1, 2, or 3 standards 
above or below the average. Specify the formatting to be applied to these cells by using the 
Format button. 
 
Format only unique or duplicate values 
Using this rule, you can format the duplicate or unique values in the selected range of cells. You 
can then specify the formatting to be applied to the values containing duplicate or unique values 
by using the Format button. 
 
To Apply Conditional Formatting 
1. Select the column to format. 
2. In the Home tab click Conditional Formatting. 
3. Select New Rule. 
4. Select the appropriate criteria. 
5. Click OK. 
 
The column will automatically format based on the criteria chosen. 
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Exercise #2 Notes 
 
Using the data in the Exercise 2 tab, add conditional formatting to: 
1. Highlight all negative values in column H. 

a. Filter by color to see the values, write them here: 
 

 

 

 
2. Highlight dates between 7/1/2015 and 9/30/2015 in column B. 

a. Sort by color  
b. Count the total number of dates ___________________ 

 
 

 

Formula Calculation Order Notes 
 
A formula in Excel always begins with an equal sign (=). The equal sign tells Excel that the 
characters that follow constitute a formula. Formulas are always calculated from left to right 
according to a specific mathematical order. The following sentence will help you remember the 
correct order. 

 
Please Excuse My Dear Aunt Sally  
P  Parenthesis 
E   Exponents (Powers or Square Roots) 
M  Multiplication or Division (left to right) 
D  Multiplication or Division (left to right) 
A  Addition or Subtraction (left to right) 
S  Addition or Subtraction (left to right) 
 

 

Exercise #3 Notes 
 
Complete the math sheet that will be passed around the room. 
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Building Formulas Notes 
 
Use of Parentheses 
To change the order of evaluation, enclose in parentheses the part of the formula to be 
calculated first. For example, the following formula produces 11 because Excel calculates 
multiplication before addition. The formula multiplies 2 by 3 and then adds 5 to the result. 
  
=5+2*3 
  
 In contrast, if you use parentheses to change the syntax, Excel adds 5 and 2 together and then 
multiplies the result by 3 to produce 21. 
  
=(5+2)*3 
 
In the following example, the parentheses around the first part of the formula force Excel to 
calculate B4+25 first and then divide the result by the sum of the values in cells D5, E5, and F5. 
  
=(B4+25)/SUM(D5:F5) 
 
 
Formulas 
A formula performs calculations or other actions in your worksheet. A formula always starts with 
an equal sign (=), which can be followed by functions, references, operators, and constants. 
 
Functions – A prewritten formula that takes a value or values, performs an operation, and 
returns a value or values. Use functions to simplify and shorten formulas on a worksheet, 
especially those that perform lengthy or complex calculations. 
 
References – The set of coordinates that a cell occupies on a worksheet. For example, the 
reference of the cell that appears at the intersection of column B and row 3 is B3. 
 
Operators – A sign or symbol that specifies the type of calculation to perform within an 
expression. There are mathematical, comparison, logical, and reference operators. 
 
Constants – A value that is not calculated and, therefore, does not change.  
 
 
The 4 Types of Calculation Operators 

 Mathematical (or Arithmetic) 

 Comparison 

 Text Concatenation  

 Reference 
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Mathematical Operators  
 

To… Use this symbol Example 

Multiply * 9*9 
Divide / 81/9 
Add + 8+1 
Subtract 
Denote negative numbers 

- 10-1 
-9 

Percent % 90% 
Exponentiation ^ 3^2 

 
Comparison Operators – compare two values 
 

Comparison Operator Means Example 

= Equal to A7=B7 
> Greater Than A7>B7 
< Less Than A7<B7 
>= Greater than or equal to A7>=B7 
<= Less than or equal to A7<=B7 
<> Not equal to A7<>B7 

  
Concatenation Operator – join values/text 
The operator & is used to join one or more strings of text to produce a single piece of text.   
 
Reference Operators- combine ranges of cells for calculations 
 

Reference  Operator Means Example 

: (colon) Range operator which produces 
one reference to all cells between 
two references. It includes the two 
references. 

SUM (C1:E17) 

, (comma)  Union operator which combines 
multiple references into one. 

SUM(C1:C4, A3:D5) 

(space) Intersection operator, which 
returns a reference to the cells 
common to the ranges in the 
formula. In this example, cell C7 is 
common, so it is the intersection. 

B7:D7 C6:C8 

 
To Create a Formula 
1. Click in the cell where you would like the result of your formula to appear. 
2. Type the equal sign (=). 
3. Enter your formula by typing in the cell reference or clicking on the desired cells. Use the 

desired mathematical symbols and operators to complete your formula. 
4. Hit the Enter key. 
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Exercise  #4 Notes 
 
1. Utilize the Exercise 4 tab and your Exercise 3 math worksheet to enter the formulas into 

Excel and check your answers. 
 
 

 

The Syntax of Functions Notes 
 
Functions are predefined formulas that perform calculations by using specific values, called 
arguments, in a particular order, or structure. Functions can be used to perform simple or 
complex calculations. 
 
Structure of a Function 

 Structure – The structure of a function begins with an equal sign (=) followed by the function 
name, an operating parenthesis, the arguments for the function separated by commas, and a 
closing parenthesis. The structure in the screenshot below is =SUM(B2:B5). 

 Function Name – A complete list can be found by clicking in a cell and pressing Shift+F3. The 
function name in the screenshot below is SUM. 

 Arguments – Arguments can be numbers, text, logical values such as TRUE or FALSE, arrays, 
error values such as #N/A, cell references, constants, formulas, or other functions. The 
argument in the screenshot below is (B2:B5). 

 Argument Tooltip – A tooltip with the syntax and arguments appears as you type the 
function, displaying only built-in functions. The argument tooltip in the screenshot below is 
SUM(number1, [number2], …). 

 

 

 

 

Exercise #5 Notes 
 

1. Navigate to the Exercise 5 tab. 
2. Enter formulas as necessary to perform the calculations. 
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Other Functions Notes 
 

=A1+A2+A3 Adds the values in cells A1, A2 and A3 

=SQRT(A1) Uses the SQRT function to return the square root of the value in A1 

=TODAY() Returns the current date 

=UPPER(“hello”) Converts the text “hello” to “HELLO” by using the UPPER function 

=IF(A1>0) Tests the cell A1 to determine if it contains a value greater than 0 

=TRIM Removes extra spaces from the specified cells 
 
 

 

Concatenate Notes 
 
The concatenate function plus & is used to join one or more cells into one single cell. An 
example would be joining Last Name from one cell and First Name from another cell. 

 
=CONCATENATE(C2&"."&B2&"@fakemail.com") 

 
TIPS: 

 Click on cells, don’t type cell addresses. It is faster and easier. 

 An ampersand (&) must be present between items you wish to join. 

 Add spaces, characters or text between “ ”. 

 The formula =C2&”.”&B2&”@fakemail.com” would accomplish the same result as 
=CONCATENTATE(C2&”.”&B2&”@fakemail.com”) 

 

 

Exercise #6 Notes 
 
Utilizing the Exercise 6 tab and the functions listed above, perform the following: 
1. Trim the extra spaces from the data in the Address column. 
2. Capitalize the information in the State column. 
3. Use a formula to enter e-mail addresses in column F using the format:  

First Name.Last Name@fakemail.com 
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Subtotals Notes 
 
You can automatically create subtotals and grand totals by using the Subtotal command. 
 
1. Click the Data tab. 
2. Sort the data. 
3. In the Outline group select Subtotal. 
4. Select the criteria for subtotaling. 

 

5. Click OK. 
 

 

Exercise # 7 Notes 
 
Using the data in the Exercise 7 tab of the Formulas and Functions Exercises workbook, add 
automatic subtotals to the earnings amount. 
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Remove Duplicates Notes 
 
When you use the Remove Duplicates feature, the duplicate data will be permanently deleted. 
Before you delete the duplicates, it’s a good idea to copy the original data to another worksheet 
so you don’t accidentally lose any information. When you remove duplicate values, only the 
values in the range of cells or table are affected. Any other values outside the range of cells or 
table are not altered or moved. 
 
1. Click the Data tab. 
2. In the Data Tools group click on Remove Duplicates. 

 

3. The dialogue box will open and automatically populate the columns in the current 
spreadsheet. 

  

4. Check the box next to the columns from which you would like to remove duplicates.  
5. Click OK. 
6. The rows containing any duplicate data will be removed and Excel will display the number of 

duplicate values removed and the number of unique values that remain. 
 

 

Exercise #9 Notes 
 
1. Using the data in the Exercise 9 tab of the Formulas and Functions Exercises workbook, 

create a list of employees (removing duplicates) with their Paygroup, Name, Home 
Department and Combo Code. 

2. What is the total number of employees ________________________ 
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Exercise #10 Notes 
 
Using the data in the Exercise 10 tab of your Formulas and Functions Exercises workbook and 
the skills practiced in this session, format the worksheet as follows: 
 
1. Remove any duplicates. 
2. Split column A into first and last name. 
3. Create an e-mail address column using the following email convention:  

FirstName.LastName@fakemail.com 
4. Remove the extra spaces in the address column. 
5. Change the state column to upper case. 
6. Subtotal the spreadsheet to produce sales totals by city (you will need to sort first). 
7. Enter the sales totals below: 
 

Bellevue  

Kirkland  

Redmond  

Seattle  

Grand Total  
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Audit a Formula  Notes 
 
Using the auditing commands in the Formula Auditing group on the Formulas tab, you can audit 
formulas in a worksheet by tracing precedents and dependents, checking errors, and stepping 
through a formula.  

 

Tracing Precedents and Dependents 
A formula that you add in a cell is always dependent on other cells referenced in the formula. 
The Trace Precedents option in Excel helps you find all the cells that a formula depends on. To 
trace precedents of a formula: 
1. Click the cell that contains the formula. 
2. On the Formulas tab, in the Formula Auditing group, click Trace Precedents.  
3. Excel marks all the dependent cells with blue tracer arrows.  
 
Similarly, a worksheet can contain several formulas that are dependent on the value of one cell. 
To view cells that contain formulas that depend on the value of a cell: 
1. Select the cell that contains the value. 
2. On the Formulas tab, in the Formula Auditing group, click Trace Dependents. 
You can use the Remove Arrows command in the Formula Auditing group on the Formulas tab 
to clear the arrows displayed when tracing precedents and dependents in the worksheet. 

TIP: To view all the formulas in a worksheet, click Show Formulas in the Formula Auditing 
group on the Formulas tab. 

Error Checking 
Using the Error Checking option in the Formula Auditing group, you can find errors in a formula. 
The Error Checking dialog box displays the errors in the formulas. You can find help about the 
error, edit the formula in the formula bar, and ignore the error if required. Use the Previous and 
Next commands to view the other errors in the worksheet. 
 
Stepping Through a Formula 
To step through complex formulas, use the Evaluate Formula command in the Formula Auditing 
group on the Formulas tab. In the Evaluate Formula dialog box, Excel displays the formula. You 
can evaluate the value of each expression in the formula and then calculate the final result. Excel 
helps you step through the formula, one expression at a time, and evaluate the final result for 
the formula. 
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Error Messages Notes 
 

When a formula is created in Excel that contains an error or circular reference, Excel will display 
one of a handful of error messages. Knowing the meaning of these error messages helps in 
identifying the underlying problems, and in correcting the error. 
 

Error Meaning 

#DIV/0! Appears when the formula calls for division by a cell that either contains the 
value 0 or, as is more often the case, is empty. Division by zero is a not 
allowed in mathematics. 

#N/A! A formula or a function inside a formula cannot find the referenced data. 

#NAME? Appears when the formula refers to a range name that doesn't exist in the 
worksheet. This error value appears when the wrong range name is typed or 
quotation marks are not used to enclose some text used in the formula, 
causing Excel to think that the text refers to a range name. 

#NULL! Appears most often when you insert a space (where a comma should have 
been used) to separate cell references used as arguments for functions. 

#NUM! Appears when Excel encounters a problem with a number in the formula, 
such as the wrong type of argument in a function or a calculation that 
produces a number too large or too small to be represented in the 
worksheet. 

#REF! Appears when Excel encounters an invalid cell reference, such as when you 
delete a cell referred to in a formula or paste cells over the cells referred to 
in a formula. 

#VALUE! Appears when the wrong type of argument or operator is used in a function, 
or when a mathematical operation refers to cells that contain text entries. 
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Using What-if Analysis Notes 
 
In Excel, you can save different sets of values as scenarios that you can substitute as required in 
a worksheet. You can switch between the different scenarios to compare the different results.  
 
Create Scenarios 
1. Select the cells that will contain the set of values of the scenarios. 
2. On the Data tab, in the Data Tools group, click What-If Analysis. 

 
3. Click Scenario Manager.  
4. In the Scenario Manager dialog box, click Add. 
5. In the Add Scenario dialog box, in the Scenario name box, type a name for the first scenario. 
6. Click OK. 
7. In the Scenario Values dialog box, type the values for the first scenario. 
8. Click OK. 
9. Similarly, create other scenarios. 
 
The Scenario Manager dialog box displays the scenarios that you created. You can simply select 
a scenario and click Show to view the results. You can delete a scenario by using the Delete 
button in the Scenario Manager dialog box. 
 
To use values or data from other worksheets in the scenarios you created, merge the scenarios. 
After collating all scenarios, create a scenario summary report that includes information from all 
the scenarios. Excel displays the scenario summary report in a new worksheet. 
 
Merging Scenarios 

1. On the Data tab, in the Data Tools group, click What-If Analysis. 
2. Click Scenario Manager.  
3. In the Scenario Manager dialog box, click Merge. 
4. To merge the required scenario, in the Book list section of the Merge Scenarios dialog box, 

select the required workbook. 
5. In the Sheet box select the required worksheet, then click OK. 
6. In the Scenario Manager dialog box, click Close. 
7. The Scenario Manager dialog box displays the merged scenario. 
 
Summarizing Scenarios 

1. On the Data tab, in the Data Tools group, click What-If Analysis. 
2. Click Scenario Manager.  
3. In the Scenario Manager dialog box, click Summary. 
4. In the Scenario Summary dialog box, select the required result cells, and then click OK. 
5. Excel displays the summary report in a new worksheet named Scenario Summary. 
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Additional Resources Notes 
 
To contact me directly: 
 
Brett Neal – Professional Development & Training 
802-656-0630 
brett.neal@uvm.edu 
 
NOTE: If you are having problems with a spreadsheet, sending me a copy will make it easier for 
me to help you! 
 
 
Additional Resources: 
To view all classes offered by Professional Development & Training, go to our website 
http://www.uvm.edu/develop. Here you can view the class schedule by date, read class 
descriptions, learn about the certificate programs we offer, and find PeopleSoft Mini Manuals. 
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